Union Institute & University Homepage
Login |

Help Center

Technical Specifications

Before you continue check the requirements below. If you have any problems, call one of UI&U's librarians (1-888-828-8557 x8747 or email library@myunion.edu).

1. Browser You'll need at least Internet Explorer 8.0, Firefox 12, or Chrome 9  to use the Library Research Guide. You can go to either the Mozilla Firefox, Google Chrome or Microsoft site; they will tell you what version you are currently using. If it is lower than the recommended version, you'll need to download a higher (free) version from their site.

2. Javascript. A majority of the research guide content is available without Javascript enabled, however some demonstrations require Javascript to function properly. Contact library@myunion.edu if you have any questions.